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Introduction 
The U.S. Environmental Protection Agency’s (EPA’s) 305(b) Assessment Database 

(ADB) software was developed as a tool for State environmental agencies to ease the burden of 
State reporting of water quality assessment data. EPA supported the development and 
distribution of the ADB software to encourage standardization of reporting between states; and 
to facilitate the generation of the National Assessment Database and the biennial National Water 
Quality Inventory. The main function of the ADB version 2 (ADB v.2) is to store assessment 
information in a way that is consistent with EPA’s Guidance for 2006 Assessment, Listing and 
Reporting Requirements Pursuant to Sections 303(d) and 305(b) of the Clean Water Act (EPA, 
2005); henceforth referred to as the Guidance, which is available at:: 
http://www.epa.gov/owow/tmdl/2006IRG/report/2006irg-report.pdf.  In the 2006 Guidance, EPA 
encouraged States to integrate the reporting requirements under Sections 305(b) and 303(d) of 
the Clean Water Act (CWA). ADB v.2 is designed to facilitate the integration of the two 
programs and produce attainment category reports, as defined by the Guidance, based on the 
assessment information in the database. 

System Overview 
The ADB v.2 is a relational database application with an Oracle, a Microsoft (MS) 

Access, or a SQL Server database platform and a Visual Basic user interface. The ADB includes 
two files, a user interface file and a database file. The user interface file must be installed locally 
on each user’s machine. This file contains all of the graphical screens and tools that allow the 
user to enter and view data. The second file is a database file that stores all of the data. This file 
may be stored on an individual machine or on a server for access by multiple users. The 
advantage of the two-file design is that the graphical interface can be improved without affecting 
the table structure or data stored in the database file. 

The user interface for the MS Access version of the ADB v.2 is virtually the same as that 
for the SQL Server and Oracle versions; however, choosing to use the MS Access version does 
not allow the user to take advantage of the power of the Oracle and SQL database. MS Access 
ADB v.2 users will sacrifice (1) a more secure data storage environment and the ability to create 
user profiles with specific data privileges; (2) the ability to restore lost or corrupted data and 
significantly lower incidence of database corruption; (3) data back-up features; (4) increased data 
storage capacity (the Oracle version of ADB v.2 can store data that could easily exceed the 2 
Gigabyte storage capacity in Access); (5) web servability.  

Getting Started 
Installing the ADB 

For detailed instructions on installing the ADB, see Appendix A of the ADB Users Guide, 
available from the Reference section at http://www.epa.gov/waters/adb. There are two parts to 
the installation of the ADB: installing the user interface such as data entry and viewing forms, 
and installing the database (the actual data tables). You may want to have your database 
administrator (DBA) handle the database installation for you. 
Microsoft Access 

After installing the ADB interface, you will have a new item on your Start->Programs 
menu in Windows called ADBv.2 for Access. Select ADBv.2 from this menu to start the 
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application. You will be prompted to navigate to the ADBaccess.mdb database if you see the 
following message: 

  

The first time you start the ADB, you will be prompted to select the State with which you 
will be working. If no data exist for the current cycle, you will be asked if you want to begin 
working on the current cycle. If you click No, you will then be asked to select an existing cycle. 
The ADB will default to this selected State and cycle the next time you start the ADB. You can 
change the State and cycle you are working with at any time using the Data menu. 
Installing the Sample Data 

Unzip the contents of the Regional.zip file into the “Regional_SampleData” folder on 
your C: drive. 

Tutorial Organization 
This tutorial uses sample data that come with the ADB v.2. All the exercises include text 

descriptions of the program functions and associated concepts as well as step-by-step instructions 
that you should follow on your PC. The step-by-step instructions are included in gray text boxes, 
separate from the text, as shown below. 

1. This is an example of a text box that contains instructions for this tutorial. 

If you have questions about this tutorial as you work through it, please e-mail  
attainshd-hq@epa.gov. 

mailto:attainshd-hq@epa.gov
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Exercise 1. Receiving ADB data 
This exercise summarizes how to manage data that have been received an MS Access 

database or in XML format. In Exercise 1, we will import data to the sample database, learn how 
to create a copy and export data for a particular State and cycle, and discuss how to replace a set 
of data without altering the entire contents of the database. 

Connecting to a State MS Access Database 
 If a State is utilizing the ADBv.2 for MS Access, the most straightforward method of 
viewing their assessment data is to request a copy of the MS Access database with which the 
ADB interfaces.  This will save you the step of importing the data.  
 

1. Open the ADB by clicking Start->Programs->ADB v.2 for Access->ADBv.2.  
2. If you have never accessed a database before using ADB, or if you have deleted or moved 

a database since you last accessed it, you will be prompted to connect to a database. 

 
  

If your computer has been used to access an ADB database before, the ADB interface 
will automatically connect to the database, State and cycle that were chosen during your last 
login. To select a new database, go to File -> Select Database and browse to the appropriate 
database when prompted.  
 

3. Navigate to the ADBaccess.mdb database located in C:\Regional Sample Data folder.   
4. If you are prompted for “State,” specify TN for State and click OK. When you get a 

message saying there are no data for this cycle, click No. 
5. Next, select 1999 for the “Choose Cycle Year” dialog box and click OK. 

 

The main ADB screen should appear. We will further explore the navigational buttons on 
this screen (Assessments, Impaired Waters 303(d), Browse, Atlas Information, Documents, 
Exit) in Exercise 3. For the purposes of Exercise 1, we will focus on the Back-up/Restore 
option available in the menu toolbar. 

Importing and Exporting Data in an XML format 
If a State has chosen to submit XML utilizing the SQL or Oracle platform of the ADB, 

eXtensible Markup Language (XML) files are the most efficient way to import and view the 
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State data.  These files will be added to a blank or existing ADB database with an MS Access 
platform. 

The Back-up feature is analogous to an export mechanism, while the Restore feature 
corresponds to an import mechanism. Historically, these features have primarily been used by 
States to save copies and reinstate copies of their data, hence the Back-up and Restore 
terminology.  The Backup/Restore option utilizes XML to easily transfer data in and out of the 
ADB data structure for individual states and/or cycles or for all data located in the specified 
database.     
Importing XML files to the ADB 

 

1. From the toolbar, choose Back-up/Restore from the Data drop-down list. 

 

If this is the first time you have received an XML import from a State (we will use South 
Carolina as an example), you may choose either the Delete and Replace option or the Replace 
option under the “Restore” dialog to import the data into your database. If you have previously 
existing data for the State and cycle located within your database, it is important to decide 
whether you would like to update the data or completely replace the data for that cycle.   
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2. Under the “Restore Options” dialog, choose the radio button next to Replace. 

You have selected Replace, so the ADB will first look to replace any matching 
Assessment Units in the database for South Carolina’s 2004 assessment cycle. Because these are 
the first data you will be loading, none will be found and the file you have just chosen will be 
loaded into the database.  

3. Click the Choose Back-up button. 

4. The Choose Location window will appear. Navigate to C:\Regional_SampleData and 
select the Open_me.txt file.  

5. Click the Restore button. It may take a few minutes to import the data. You may receive 
a message asking if you want to replace existing ADB data. Click Yes. 

6. Once the progress bar has disappeared, the data have been imported. Click Close to exit 
the Back-up/Restore screen. 

7. From the toolbar, choose Change State from the Data drop-down list. 
8. When prompted to pick a State, select SC from the drop-down list. 
9. Another prompt will appear asking if you would like to add data to the current cycle. 

Click No. 
10. When prompted to pick a cycle, pick 2004. 

You have successfully loaded an XML file that contains South Carolina’s 2004 ADB 
data.    
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All imported data files will be stored indefinitely in the ADBv.2.2 unless you choose to 
replace the data for the respective state and cycle with update files.  For example, if you have 
imported data for TN, FL and SC for the 2004 cycle and begin to import data for the 2006 cycle, 
all of the files for all cycle years will be accessible in the ADB by changing the state and cycle 
under the Data dropdown list in the menu bar. 
A NOTE ABOUT IMPORTING STATE XML FILES: 

 If a State has chosen to send their Integrated Reporting data via XML file and you 
would like to view the data using ADBv2.2, it is important to check with the state that they are 
using the latest version of ADB (version 2.2) and that the State has not modified the primary data 
elements or structural integrity of the ADB.  If the State is using a previous version of ADB or 
has altered the data outside of the interface, you may receive an error prompt when trying to 
import or ‘Restore’ state data and it may not import correctly.  For help in loading these XML 
files, please contact EPA’s support help desk by e-mail at  
attainshd-hq@epa.gov. 
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Exporting Data in XML Format 

XML exports are performed through the Data Back-up/Restore data screen, the same 
screen we used to import XML files. You can choose to back up (export) the entire database, or 
selectively back up (export) individual States and cycles. 

1. From the toolbar, choose Back-up/Restore from the Data drop-down list. 
2. Under the “Back-up Options” dialog, choose the radio button next to Select Cycle and 

State. 

 
 

3. Choose TN for the State and 1999 for Cycle in the drop-down boxes provided. 
4. Click Back-up to begin exporting the 1999 Tennessee sample assessment data. 
5. Once the progress bar has disappeared, your 1999 TN XML file will be available under 

the C:\ADBdata\backup\TN_(current date) folder. Click Close to exit the Data 
Back-up/Restore screen. 

 

Summary 
In this exercise, you learned about the EPA’s Assessment Database (ADB v. 2) and how 

to install this system on your PC. You also learned how to import data, create a copy and export 
data for a particular State and cycle, and how to replace a set of data without altering the entire 
contents of the database.  

In Exercise 2, you will learn about the features of the Validation Module and how to use 
it to check the data you have entered in the database for completeness. 
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Exercise 2. Running the Validation Module 

In this exercise, you will learn about the features of the Validation Module and how to 
use it to check the data you have imported into the database for completeness. 

Overview    

The Data Validation Module serves two purposes:  

1. To ensure that all dates were entered properly; 

2. To run any final validation checks on the data to ensure that all of the required data 
elements have been entered.  

1. Click the Data Validation Module button at the top of the screen. 
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Finalize Cycle 

When you finish a reporting cycle, the Finalize Cycle feature can help you make sure that 
your data have all of the necessary components. The Finalize Cycle feature creates log files of all 
the errors found during a data review check. The log files will be saved in .csv text file format, 
which can be opened with a number of different software programs, including Microsoft Excel. 
These log files can be viewed by opening them in the “Finalize Cycle” dialog. The log files will 
give you a listing of all of the Assessment Units (AUs) that may have problems that need to be 
fixed. 

1. In the main “ADB Validation Checks” screen, click the Finalize Cycle button. 

2. You are going to perform all of the validations, so check all of the boxes. 

 

All of the validation checks can be run individually or in combination with other 
validations.  Validation checks perform the following operations:   

 Check Water Type - verifies that all Assessment Units have at least one 
associated water type and water size 

 Check Locations - verifies that all Assessment Units have at least one associated 
location description 
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 Check Scheduled Monitoring Dates - verifies that any Assessment Unit-cause 
combination designated as Category “4b” has an associated monitoring date. 

 Check TMDL Schedule Dates/TMDL Priority - verifies that any Assessment 
Unit-cause combination designated as Category “5” has a date or priority 
scheduled for TMDL development. 

 Check Categories - verifies that all Assessment Units have been assigned at least 
one designated use. 

 Check Causes - verifies that all causes are assigned to designated uses which are 
as not supporting or threatened. 

 Check Assessment Documentation - verifies that all assessed designated uses 
have been assigned an assessment type and confidence. 

3. Click the Begin Validation Checks button. 

4. You will be prompted to choose a location to store the log file that the Validation 
Module will create.  

5.  Click OK, then navigate to your Regional_SampleData directory and click Save. 

The Validation Module will start working, and a status bar at the top of the screen will 
indicate the progress of the check. Also, the text beside the individual boxes will change as 
checks are completed. The new text will indicate whether or not there is a problem. All of the 
validations indicate the checks are okay except for Monitoring Dates and TMDL Schedule 
Dates/TMDL Priority.  



ADB v.2 Tutorial for EPA Regional Users Exercise 2 
 
 

EPA Assessment Database Version 2 Tutorial 11  

 

 

5. Click the Open Log button beside TMDL Dates found errors. The information that 
appears in the Potential Errors text box indicates that Edisto River, Church Creek, and 
Kinley Creek are missing information. 

6. Highlight the Edisto River AU ID in the Potential Errors box to get an error 
description. 
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According to the error, total maximum daily load (TMDL) schedule dates or TMDL 
priorities must be added, because pollutants are impairing a designated use. You can add these 
dates with the Validation Module’s Check Dates feature. 

7. Click Close on the lower right corner of the dialog box. This will return you to the main 
“ADB Validation Checks” dialog box. 

Entering Dates with the Validation Module 

The Check Dates feature is provided to ensure that all dates associated with each 
assessment unit have been entered properly into the ADB. Both optional and required date 
entries may be checked in this module. Any missing dates may be entered through this screen, by 
an export/re-import of the list of dates, or by returning to the main ADB and individually 
entering the dates.  

1. Click the Check Dates button in the main “ADB Validation Checks” dialog box. 

2. Under the Select Which Dates to Work With section, click the radio button for 
Scheduling of TMDL Dates/TMDL Priority. 

3. Under the View Options section, click the Show Only IDs that require a date radio 
button. 
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4. Select the first record in the table. Under Assigned Date, type “2006” and click the 
Update button. 

You can also use the calendar button to choose a year in the Assigned Date field. Notice 
that when you update a record, the record disappears from the table.  

Note: Adding a TMDL schedule date does not change the category. 

5. Repeat the step for the next two records. 

 



ADB v.2 Tutorial for EPA Regional Users Exercise 2 
 
 

EPA Assessment Database Version 2 Tutorial 14  

It is understood that the person entering the assessment data in the ADB V.2 may not be 
the same person who determines the crucial dates (i.e., date scheduled to receive a TMDL) for 
the AUs. The Enter Dates feature in the Validation Module also allows you to export a list of all 
the items requiring a date to a .csv file that can be opened using Excel. This file can be sent to 
the person responsible who can fill in these crucial dates and return the file to the person 
responsible for the ADB. You can then import this file to the Validation Module and all of the 
crucial dates will be updated according to the dates entered in the .csv file.  

6. Under the Select Which Dates to Work With section, click the radio button for 
Monitoring Dates. 

7. Under the View Options section, click the Show Only IDs that require a date radio 
button. 

Several AUs require a Monitoring Date. In this case, it may be most efficient to export 
the list, fill in the dates as an Excel spreadsheet, and re-import the list with the dates.  

8. Click the Export List button located in the upper middle of the window. Save the file as 
“Monitoring_date_export” in your Regional_SampleData folder. 

 

 

9. Go to your Regional_SampleData folder and open the Monitoring_date_exports.csv. 

10. Under the Monitoring Scheduled Date column in the spreadsheet, enter “2006” for all of 
the AUs (TIP: The simplest way to fill in the entire column is to fill in the first cell, then 
click the lower right corner of the cell. Keep the mouse clicked as you drag it to the last 
row you wish to fill.) 
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11. When all of the rows in the Monitoring Schedule Date have been filled, Save and Close 
the spreadsheet. 

12. Return to the “Date Validation” screen. Click the Import List button located directly 
under the Export List button. 

13. Navigate to the Monitoring_Date_Export.csv file and click Open. 

14. The “Import Data from File” screen will appear. You will need to match the ID305B and 
Data columns from the Monitoring_Date_Export.csv to match the headers in the ADB. 
Use the drop-down lists to fill in the ID305B and Data columns as appears below. 
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15. Click the Import button at the top right of the “Import Data from File” screen. A 
prompt box will appear notifying you that the import is complete. Click OK to return to 
the “Date Validation” screen. 

The records should now be absent from the table. 

16. Click CLOSE. This will return you to the main “ADB Validation Checks” screen 

After you have resolved any issues discovered in the initial round of validation checks, 
you can use the “Finalize Cycle” screen to ensure that all the necessary components are now 
located in the database. 

17. Click the Finalize Cycle button. 

18. Check only the boxes for Check Monitoring Dates and Check TMDL Schedule 
Dates/TMDL Priority, and click the Begin Validation Checks button. Save the log 
file in your Regional_SampleData folder. 
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The Validation Module indicates these files are OK.  

19. Close the “Finalize Cycle” dialog and Exit the “ADB Validation Checks” screen. 
 

Summary 

In this exercise, you learned about the functionality of the Validation Module. You 
learned how to use the Finalize Cycle feature of the Validation Module to check the entries in 
the database for the presence of required information, and you learned how to enter a required 
date using the Check Dates feature.  

In Exercise 3, you will learn how to browse and review data as well as view 
documentation and atlas information in the ADB v.2. 
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Exercise 3. Exploring ADB v.2  

How to Browse and Review Data; View Documentation and Atlas Information.  

 

The main screen of the ADB v.2 features six directional buttons: 

 trative privileges, you 
 

aters 303(d) – This button allows a user to view information about impaired 

database, even if (s)he does not 

ize of 

Assessments – If you log into the database as a user with adminis
can use this button to add and make changes to the assessment data in the database using
this button. 

 Impaired W
Assessment Units (AUs) and manage their categories. 

 Browse – This button allows a user to view data in the 
have administrative privileges to add, update or delete assessment information. 

 Atlas Information – This button allows a user to independently track the total s
waterbodies in the State according to each source and/or scale cited.  



ADB v.2 Tutorial for EPA Regional Users Exercise 3 

 5M Documentation – This button allows you to enter a URL or description of the 
mercury program and how the program meets the recommended elements, which are both 
required by the Clean Water Mercury Guidance if using subcategory 5M.  

 Exit – This button closes the ADB v.2. 

Browsing the Assessment Data 

The Browse features provide a quick, easy way to access information in the ADB. 
Administrative privileges are not required to access the Browse features Thus, people in your 
agency may access database information through Browse without threatening the integrity of the 
data. 

1. From the toolbar, choose Change State from the Data drop-down list. 

2. When prompted to pick a State, select TN from the drop-down list and click OK. 

3. Another prompt will appear asking if you would like to add data to the current cycle. 
Click No. 

4. When prompted to pick a cycle, pick 1999 and click OK. 

Full Browse 

1. From the main ADB screen, click the Browse button, then click the Full Browse 
button. 

 

 

The Full Browse option allows you to see all of the data in the database by tabbed 
sections. You can click on different tabs to view the different types of data in the ADB v.2. 
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When examining the tables, you can click on the field names and the table will be sorted by that 
field. You can control the sort order using the Order by: drop-down list. Clicking on a field 
name also populates the Search in Active Column for: list box with all of the values from that 
field. This allows you to quickly locate the specific values you are interested in reviewing.  

2. Click the Uses tab and then click the USE DESC field. This sorts the table by Use 
Description. 

3. Choose Fish and Aquatic Life from the Search in Active Column for: drop-down list. 
Click GO. This will take your pointer to the first record that has Fish and Aquatic Life 
in the USE DESC column. 

You can scroll through the list and see which AUs are “Fully Supporting” the Aquatic 
Life Use, which are “Not Supporting,” and which have “Insufficient Information.” You can 
search for data in other tabs in the same way. Feel free to examine the other data available 
through this Browse feature.  

If you want to export the data in your “Browse” screen, click the Export button. This 
will create a comma delimited (.csv) file in a location that you specify. 

4. Click the Close button, located in the top left corner, when you are finished exploring 
the Browse feature. 

Browse by Category 

This dialog features the same tabs as the “Browse” dialog; however, the information 
shown for each tab only applies to the AU that is currently selected in the Assessment Units table 
on the upper left part of the screen. Similar to the other Browse tables, you can sort this table by 
clicking on one of the columns, and then can search for values in the active column. This feature 
is particularly useful if you want to look at the information associated with a specific AU.  

1. In the “Browse Options” dialog box, click Browse by Category. Select Category 5 
from the Select a Category drop-down list. 
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The database selects all the AUs that are in Category 5, in other words, it selects all AUs 
that are impaired or threatened for one or more designated uses by a pollutant(s) and require a 
Total Maximum Daily Load (TMDL). From the screen, you can view the number of AUs, the 
water types, and the associated total sizes in the selected category. 

2. Click the CLOSE button twice to return to the main database screen. 
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Viewing Atlas Information 

The Atlas Information feature is new to ADB v.2.2. It allows the user to:  

 Include information for water types that may not be supported for individual AUs (e.g., 
canals)  

 Store the number of waterbodies as indicated by various geographic scales  

 Report the total sizes of waterbodies according to several sources.   

The data stored within the Atlas Information fields are independent of data related to 
individual AUs, and therefore do not affect the assessment calculations or reports produced by 
the ADB. From the Atlas Information screen, you can view, create, update, and delete records. 

1. From the main database screen, click Atlas Information. 

 

 

2. Click Close to return to the main ADB screen. 
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Impaired Waters 303(d) 

The Impaired Waters 303(d) feature works similarly to the Browse feature. It allows you 
to view causes by Category, TMDL ID, 303(d) Listing IDs, Cause, and Source. You can update 
the data through the Manage Causes button. 

1. Click the Impaired Waters 303(d) button. The “Impaired Waters” screen will appear. 

 

 

You can view impaired waters by choosing one of the Selection Options. Note that you 
may not get results if there are no data in the ADB that meet the selection criteria. For example, 
if you select Choose IDs by Category and you pick Category 4B in the drop-down box, no 
AUs will appear in the listbox unless you have specified that an impaired use is expected to meet 
attainment for at least one AU. 
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2. Click the radio button beside Choose by Cause. Next, make sure the radio button for 
Specific Codes is selected and choose Fecal Coliform from the drop-down list. 

 If you had clicked General Codes, you would have been able to choose from general 
cause categories such as Metals and Pathogens. 

 

3. Select TN06030003001_0500 Sinking Creek from the ID list. 

Now you can view the data associated with the AU by clicking the tabs in the same way 
that you did in the Browse feature. You can also click the Manage Causes button to add 
TMDLs, 303(d) IDs, Expected to Attain Dates, and Implementation Actions.  

Note: 303(d) List IDs, like AU IDs, are unique identifiers for water segments. 303(d) List 
IDs uniquely identify Category 5 waters, and are separate from an AU ID. 

4. Click the Manage Causes button to the right of the ID list. The “Cause Information: 
303(d)” screen will appear. 

5. Select the Fecal Coliform impairment in Category 5. Hold down the left mouse button 
and drag the impairment to Category 4A. The “Assign TMDLs” screen will appear. 

If this is your first time using the ADB, the list of TMDLs must be downloaded before 
you can view and assign TMDLs to an AU.  

6. Click the Refresh TMDL Snapshot button located midway down on the right side of 
the page. The list of TMDLs will begin downloading. The download may take a few 
minutes to complete. 

The most current list of EPA-approved TMDLs is kept in the National TMDL Tracking 
System (NTTS). Each time you refresh the TMDL snapshot, the ADB downloads a recent 
version of the TMDL list to your hard drive. Therefore, you will want to click the Refresh 
TMDL Snapshot button every few weeks to ensure that you are viewing current TMDL 
information. The date of the last snapshot is located in the upper right corner of the screen. 
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7. Scroll through the list of TMDLs until you find the Sinking Creek TMDL. 

8. Select Sinking Creek TMDL and click View TMDL Information. This will open a 
new window and direct you to the TMDL stored on the EPA Web site. 

9. When you are finished viewing the TMDL, Close the Internet window and return to the 
ADB. 

10. Now click Assign TMDL to Cause. A prompt will appear asking if this is a delisting. 
Click No. 

The TMDL has now been associated with the AU.  

11. Close the “Assign TMDLs,” “Cause Information: 303(d),” and “303(d) Impaired 
Waters” screens to return to the main ADB screen. 
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Exporting 303(d) lists 

You can also export 303(d) information to comma-separated value format through the 
Data dropdown list in the menu toolbar.   

1. Click Data Exports in the Data dropdown list.   
 

 

2. In the dropdown list, select 303(d) List.   

3. Click the Export Data button.  The “Choose Location” window will appear. 

4. Save the file in your Regional_SampleData folder.  

5. Close the Data Exports window. 
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Mercury Reduction Strategy (5M) Documentation 

The 5M documentation feature of the ADB allows you to add a 5M related website link 
(URL) and comments to the database using plain text or Rich Text Format (RTF). RTF allow 
you can create comments that are formatted for easy reading, as well as add color, bullets, 
bolding, underlining, italicizing, different fonts, and font sizes.  

 

If you have an existing text or rich text file containing 5M comments, you can import 
them by using the Get From File button on the lower middle of the “Mercury Reduction Strategy 
Documentation” window. Use the “Choose Location” window to navigate to the location where 
the file is saved and click Open. The Comments text box should now contain the contents of 
your file. Click Save to associate the text with the cycle. You can also save the 5M comments to 
a separate text or rich text file by clicking the Save to File button and navigating to where you 
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would like the file to be located. You can then use the Open File button to retrieve your saved 
comments. 

Summary 

In this exercise, you learned how to view, sort, and export data in the ADB using the 
Browse features; view assessment information associated with impaired waters; access a 
Monitoring Strategy and/or Assessment Methodology document located in the ADB; add Atlas 
Information; manage causes using the “Impaired Waters: 303(d) Information” screen, and view 
data in the ADB v.2 using the sidebar buttons on the “Assessment Units” screen. 

In Exercise 4, you will learn how to add and modify Assessment information, including 
how to add causes of impairment to existing IDs. 
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Exercise 4. Adding and Updating Assessment Information  

This exercise will show you how to add a new AU, how to assign designated uses, and 
how to enter use support information to the ADBv2.  You will also learn how to assign new 
causes to existing assessment units. 

Adding an Assessment Unit 

1. In the main database screen, click the Assessments button. 

2.  Click the Create New Assessment Unit button on the Assessment Units screen.  A 
dialog box will appear requesting that you add Assessment Unit ID, Name, and 
Location Description.  All of these data elements are required.  The database will not 
allow you to proceed without entering information in each box.  Fill out the dialog box 
using the following information and then click Add. 

 

Note: If you are attending a class where you are using the ADBv2 over a network, each student 
must use his/her own AU ID.  Otherwise, you will all be accessing the same record and cause 
problems with the exercise.  The instructors will assign you a letter to use in place of the x.  For 
example, if the instructors assign you the letter A, each time you see “AU-1x” use “AU-1a.”  

 Next, a dialog box will appear requesting you to add Assessment Unit Information.  The 
Water Type drop-down list contains a number of different kinds of waterbodies that you can 
choose from to describe the water in your AU.  Your AUs can be composed of multiple 
waterbody types.  Define one type first, and then you can define the others later.  The Size units 
depend on the Water Type that you choose. 

2.  Choose Creek in the Water Type dropdown list and enter “3” as the size in MILES and 
click Add. 

The information you just entered will be displayed on the Assessment Units screen. 
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Adding Designated Uses, Use Support, and Assessment Metadata 

3.  Click the Add Uses button to assign designated uses to this assessment unit. 

 

4.  Select the Fish and Aquatic Life, Irrigation and Livestock Watering and Wildlife 
designated uses (to select non-sequential items in the list, hold down the Control key) and 
click ADD. 

Note: The Designated Uses listed are from EPA’s Water Quality Standards Database (WQSDB), 
which is populated with the data from the States’ Water Quality Standards (WQS) documents.  If 
a Use is not specified in your WQS document, it will not be available in this list.  For more 
information on the WQSDB, visit http://www.epa.gov/wqsdatabase. 

5.   Double-click on Fish and Aquatic Life to add an assessment to that Designated Use. 
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 The Assessment Documentation screen will appear.  This screen allows you to add use 
support status, assessment data, assessment types, assessment methods, user flags, and 
threatened status flags to the selected designated use.  The Use Support field is always required 
for each designated use.  All other fields are considered assessment metadata and are either 
conditionally required or optional. 

6.  In the Use Support drop-down box on the “Assessment Documentation” dialog box, 
choose Fully Supporting. 

 

When use support status is changed from not assessed, assessment type and assessment 
confidence information must be entered as well before you can return to the Uses screen.  
Available Assessment Types and Confidence of Assessment are the only conditionally required 
metadata elements.  Therefore, if you delete all of the assessment types associated with a 
designated use, the use support will be changed to “Not Assessed.”   

7. Under “Assessments Performed,” click on ADD to specify Available Assessment Types 
and Confidence of Assessment. 

8. A prompt box will appear to ask if you would like to save these changes.  Click Yes and 
the “Add Assessment Metadata” dialog box will appear.  Enter the information specified 
below: 
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There are seven assessment types available to choose from in the drop-down box: 
Biological, Habitat, Physical/Chemical, Toxicological, Pathogen Indicators, Other Public 
Health Indicators, and Other Aquatic Life Indicators. Further information on assessment 
types is available on page 21 of the ADB User’s Guide.   

 Four levels of confidence or quality of the data used to make the assessment can be 
associated with these assessment types:  Low, Fair, Good, and Excellent.  How a state assigns 
assessment type and confidence should be explained in its Assessment Methodology Document.  

9. Click ADD to return to the Assessment Documentation screen. 

Feel free to explore and enter other types of assessment metadata on this screen.   

Note: Changing threatened status will change the designated use to be considered impaired, 
affecting the category definitions.  Be sure to leave this button set to “No” when saving changes 
to the assessment metadata to avoid obtaining different category definitions in the following 
exercise section.     

 The user should be certain that a given metadata category is related to the specific use 
being assessed.  For example, it would not make sense to have a Habitat assessment associated 
with a Primary Contact Recreation use.  The State’s Assessment Methodology Document should 
describe what types of assessment metadata categories can be associated with each WQS 
designated use. 

10. Click Save.  Then click the “Uses” icon to return the Uses screen. 

 

11.   Click the Assessment Units button to return to the main “Assessment Units” screen. 

 

EPA Assessment Database Version 2 Tutorial 32 



ADB v.2 Tutorial for EPA Regional Users Exercise 4 

Adding Causes of Impairment to Existing Waters 

When Assessments is selected from the main dialog, the user is able to access assessment 
information for any AU in the database, and then view, add, update, or delete AU information 
from this screen.  

Assessment information associated with an AU may include designated uses, assessment 
metadata, causes of impairment (or observed effects), sources of impairment, and assessment 
category. Access this information using the buttons on the sidebar at the left. 

1. In the “Select an Assessment Unit” dialog box, choose Dry Creek from the or by Name: 
drop-down list and click GO. 

 

 

 

Dry Creek is associated with several AUs, so you will need to select a specific AU before 
you can look at AU information.  
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2. Select TN05130107023_2000 and click OK. 

The database will retrieve information for the AU specified, displaying the Assessment 
Unit ID as well as the Location Description and the Water Type and Size. The text beside the 
sidebar buttons indicates some additional information about the AU, such as whether or not there 
is information for each of those data elements and, if so, how many uses, causes, or sources 
exist. This sidebar indicates this AU has three uses and two causes. 
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Causes and Designated Uses 

1. Click the Uses button. 

 

2. Highlight Irrigation and then click the Change Use Support button. 

  
3. Highlight Not Supporting and then click the Change button. 

4. Click the Causes button. 

 

The “Causes” dialog indicates that no causes for the Irrigation use have been added yet.  
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3. Click the Add button.  The Add Causes screen will appear. 

 

The Add Causes screen will automatically default to show the causes which are currently 
being utilized in the database.  If you would like to view all causes housed in the ADB or view 
causes by a characteristic group (e.g. pathogens, pesticides), choose the radio button nest to 
SHOW ALL or SHOW ONLY. 

  4. Highlight Chlorine.   

 Additional Information on highlighted causes, such as the CAS Registry number or 
priority status under the Clean Water Act, will appear in the Information window.    

 

5. Click the ADD button to associate chlorine with the Irrigation designated use for Dry 
Creek.   

6.     Click the Assessment Units button to return to the main “Assessment Units” screen. 

 

Summary 

In this exercise, you have learned how to add a new AU, how to assign designated uses, 
and how to enter use support information to the ADBv2.  You also learned how to assign new 
causes. 

In Exercise 5, you will learn how to use the Reports Module, including how to create 
standardized reports.  
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Exercise 5. Reports Module 

In this exercise, you will learn about the features of the Reports Module and how to use it 
to create and print out standardized reports. 

Overview 

The Reports Module can create summary reports for a selected state, water type, and 
cycle. It can also generate comprehensive reports for selected AUs.  

1. Click on the Reports Module button at the top of the main ADB screen. 

 

If you are not already logged in to the ADB, access the Reports Module by clicking on 
Start->Programs->ADBv2 for [version]->Reports. 
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Creating State Reports 

State Reports were a new feature in the ADBv2.2. The following are the six reports that 
are available under this dialog: 

 Assessment Unit Summary List – This report has general information associated with 
the  assessment unit including, AU Name, Water Type, Water Size, Location 
Description, Use  and associated Attainments, Causes, Sources, and TMDL Status. 

 303(d) List Report – This report shows all waters on the 303(d) list with their 
associated causes, TMDL status, uses, and sources. 

 303(d) Delisting Report – Any delisting information entered into the ADB is 
available here. The 303(d) delisting report is a simple way to track the delisting status 
of all AUs in the database. 

 WQS Attainments Report – This report contains information for waters that have been 
removed from the list due to WQS attainment reasons. 

 TMDL Status Report – This report lists all of the AUs that require a TMDL and any 
information the user has entered regarding the progress towards submitting a TMDL. 
TMDL progress information can be entered through the TMDL information in the 
upper right corner of the Causes screen.  

 
 Atlas Report – This report contains a summary of the waterbody information entered 

under Atlas Information and is independent of AU information in the database. 

Feel free to open and explore the state reports. Reports will appear in a separate window. 
If you wish to save a report, go to File -> Save As in the toolbar of the report window and save 
the file as a text or .html where appropriate. When you are finished, close the report window and 
click Cancel on the AState Reports@ dialog box to return to the main Report Selection screen. 

Creating Summary Reports 

With the Reports Module, users can create use, cause, and source summaries for a 
selected state, cycle, and water type. Assessment data and 303(d) data dumps can also be 
performed through the Summary Report function. 

1. Click the Summary Reports button. 

This screen allows you to specify the type of report you want to create. The Current State 
and Current Cycle represent the state and cycle selected in the ADB. You can change these at 
any time by clicking on the Data menu. Summary Reports allow the user to: 

 Generate reports by state-specific water type or general EPA water type 
 Generate summaries based on uses, causes, or sources  
 Create data dumps 
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 Produce trophic status reports on all lakes 
 Produce summaries in waterbody quality trends.  

2.  Click the button beside EPA Water Type and select Stream/Creek/River. 

 

3.  Make sure the box for Individual Use Support Summary is checked and click the 
Create New Report button. 

 
 

The report you have just created will appear in a separate window. This file will be 
available under Display Existing Report or can be found under C:\Program Files\ADB v.2\ 
Modules\XML_Report\report.html, but this file will be overwritten whenever another report 
query is performed. If you wish to save the file permanently, go to File -> Save As in the toolbar 
of the report window and save the report as a text or .html file where appropriate. 
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4.  Close the report window by clicking the X in the upper right corner. 

 

5.  Uncheck the box beside Individual Use Support and click the check box beside Cause 
Summary. When the Cause/Source Detail check box appears, click the Include Detail 
check box to remove the check. Click Create New Report. This will list summaries of 
pollutant groups and summaries of their specific components. 

 

6.  Close the report form by clicking on the X in the upper right corner after you have 
viewed the results. 

Other report summaries can be created in the same way. Feel free to explore the types 
and variations of summary reports by varying details, water types, and report combinations. 

Creating Data Dumps 

Data dumps for assessment data and 303(d) can be created by clicking one of the buttons 
at the bottom of the form. Both reports provide the same type of information; however, the 
303(d) data dump only lists AUs that are impaired.  

1. Under “Data Dump” section of the “Summary Report” dialog box, click the New button 
for “303(d) Data.” 

The .html report will open, and you can view assessment data. Notice that there are codes 
listed in the fields for designated use, causes, and sources. There is a legend feature in the data 
dump section that includes a look-up table for these codes.  
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2. Close the table window and click the check box for Legend in the “Data Dump” section 
of the “Summary Report” dialog box.  

 

3. Click the New button under “303(d) Data.”  A new report will be generated that lists the 
code for each field and their descriptions, as well as the 303(d) data that loaded initially.  

 

4. Close the report table form and click the Cancel button on the Summary Reports screen 
to return to the main reports dialog box. 

Creating AU Detail Reports 

The AU reports allow you to choose specific AUs based on various criteria and create 
custom reports on the selected AU(s). In this exercise, we will review the types of criteria 
combinations a user can use to create unique reports. 

1. Click AU Detail Reports button. 

The AU Detail Report screen will appear. You will notice that the button next to “All 
IDs” is the default selection option. Therefore, all AUs in the database appear in the list box in 
the lower portion of the screen. You can limit the AUs by choosing any of the other button 
selection options and entering additional filtering information as requested by the report module. 
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2. Under the “Selection Options” section, select the Choose by Cause button. 

 

3. The Choose IDs by Cause box will appear to the right. Make sure that the Specific Codes 
button is selected and choose Nitrogen, nitrite from the drop-down list. 

 

The AUs listed in the lower portion of the screen will be filtered to only include those 
AUs that have Nitrogen, nitrite as an associated cause.  

4. Choose TN06010102042_1000, Beaver Creek and TN06010201067, Third Creek from 
the list box by depressing the Control key while selecting the AUs. 
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There are several ways to choose more than one AU. If you would like to select several 
consecutive AUs, you can press the Shift key while choosing the first and last AU you wish to 
include. To select all of the AUs, you can hold the Control key down and press A. You can also 
use the mouse to click and drag from the first AU you would like to select to the last consecutive 
AU you would like to select to highlight a list.  

5. To limit or add assessment information to be included in the report, click the Options 
button. The checked boxes default to Assessment Type and Comments. 

 

6. Click the OK button to return to the AU Detail Report screen. 

 

7. Click the Report button to generate the detailed report for these two AUs. 
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8. When you are finished viewing the report, close the report by clicking the X in the upper 
right corner and exit the reporting module. 

Creating Cycle Comparison Reports 

Cycle Comparison Reports is a new feature in the ADBv2.3.  This reporting feature 
allows you to select a range of information in which you can compare data from the current cycle 
to the previous cycle.  There are 5 available reports to choose from: 

 Summary Statistics – This report allows you to view the total number of assessment 
units in the current cycle compared to the previous cycle.  You can also compare the 
current cycle Assessment Unit – Cause Combinations and compare Water Sizes by 
Category for both the current and previous cycle. 

 
 Assessment Unit – Cause Combinations Added to List – This report contains any new 

assessment units and associated causes added to the 303(d) list for the current cycle. 
 

 Changed Use Attainments – This report allows you to view current and previous 
assessment unit IDs, the associated uses and how the use attainments changed from 
the previous cycle to the current cycle. 

 
 Changed Category (Assessment Unit) – This report displays overall category changes 

for an assessment unit.  You can view the current assessment unit ID and overall 
category in comparison to the previous cycle assessment unit ID and overall category. 

 
 Waters Unaccounted For – This report contains information for waters and their 

associated causes that have been unaccountable removed from the 303(d) list without 
a valid delisting reason. 
 

Summary 

In this exercise, you learned how to create summary reports and comprehensive reports 
for AUs. You also learned how to perform a data dump for assessment data. 

In Exercise 6, you will learn how to use the Connections module to connect to outside 
databases and tables. 
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Exercise 6. Using the Connections Module 

The Connections Module is designed to help you work with your data outside of the 
ADB v.2 environment as well as to help you work within the ADB v.2 environment using data 
from other databases. The Connections Module enables the user to directly access the ADB 
database and view ADB data in table format. These tables can also be exported for analysis 
outside of the ADB. Additionally, it allows the user to link to tables in other databases (i.e., 
Oracle, Access, SQL Server, or any Open Database Connectivity [ODBC] compliant database). 
This enables these databases to be viewed in the ADB. This connection could be useful, for 
example, if you want to store information about the sub-basin in which an AU is located. 

This feature is solely for the convenience of the ADB v.2 users. Any data accessed 
through the Connections Module will not be included in the electronic submission to EPA.  

In this exercise, you will learn how to connect to the ADB database to view tables within 
the Connections Module and bring a table into the ADB using the connection to the database. 
You will also learn how to use custom queries to create tables that can be exported into a .csv 
text file, which can then be used to limit the AUs viewed in the database. 

Creating a New Database Connection 

The Access database you will be using contains some assessment information that was 
collected in the field. It is stored in a single table called TN_streams in an Access data file. 

1. Open the Connections Module by clicking Start->Programs->ADBv2 for 
[version->Connections.  

2. From the File menu, select CONNECT TO A DATABASE. 
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3. In the “CONNECT TO A DATABASE” dialog box, click the Create a New Database 
Connection radio button and then click NEXT. 

 

4. From the “Connections Type” dialog box, choose Microsoft Access and click Next. 

5. In the “Connect to Access” dialog box, click on the navigation button  
 

 and navigate 
to the TN_streams.mdb database in your Regional_SampleData folder. Click Open. 

6. Next, check the Save Connection on Finish check box. This will allow you to use the 
same connection later after you close the ADB. 

7. Click Test Connection. This will let you know if the database connection is working 
properly. You should get a message saying “Test Successful.” Click OK, then click 
Finish in the “Connect” dialog box. 

8. You will be prompted to name your database connection. Call it TN_streams. Click 
OK. The Scenic_rivers table will appear in the Tables tab. 

 

9. Select the Scenic_rivers table, then right-click on it. Choose Open. The Scenic_rivers 
table will open. 
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In this example, the Scenic_rivers table contains information about AUs, including State 
basin information and an indication of whether the stream is designated as a Scenic River (“-1” 
indicates a scenic river, “0” indicates not a scenic river). Although these data cannot be stored in 
the ADB v.2, it is easy to connect to a table storing these data and to update the data while you 
work in the ADB v.2. To work with this table, you can access the following functions by making 
a column active: 

 Sort Ascending/Descending 

 Copy/Paste 

 Filter 

 Find 

 Export Data 

10. Make the STBASIN column active by clicking on the column heading, and then right 
clicking it to open the drop-down list. 

11.   Click the Sort Ascending button to organize the basins in alphabetical order. 

12. Close the table by clicking the X in the upper right corner. 

EPA Assessment Database Version 2 Tutorial 47 



ADB v.2 Tutorial for EPA Regional Users Exercise 6 

Creating a Table/Database Connection 

Now that you have created a database connection to “TN_streams,” you need to make a 
connection between the table in the database, “Scenic_rivers,” and the ADB. You must also tell 
the ADB v.2 how the fields in the Scenic_rivers table relate to the AUs. In this case, the AUID 
field in the table corresponds to AU ID in the ADB. 
 

1. Make the Scenic_rivers table active by selecting it with your mouse. Right-click the 
word Scenic_rivers in the Tables tab. Select Make New Table Connection. 

 

2. Name the connection scenic_rivers and click Next. 

3. In the “Limit Connection” screen, pick AUID from the drop-down list beside Limit By: 
Assessment Unit ID. 

 

The “Limit By:” dialog defines the relationship between the Scenic_rivers table and the 
ADB. If the table has a “Cycle” field or a “TMDL ID field,” you can further limit the records 
your table displays. For example, if you relate the cycle field in your table to the cycle in the 
database, the table will only show records for the current cycle in the database. You can limit the 
records by TMDL ID in the same way. 

4. Click Finish. When prompted, make sure the table connection is still called 
scenic_rivers and click OK. 

5. Close the Connections Module by clicking the X in the upper right corner. 
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Bringing a Table into the ADB 
 

1. Open the ADB by going to the Start menu and clicking Programs -> ADBv2 for 
[version] ->ADBv2. Click the Assessments button from the main database menu. 

2. From the View menu, choose Show Connections. From the “Existing Connections” 
screen, select the scenic_rivers entry and click OPEN. 

 

3. Click Yes when you are asked if you want to enforce limits for the connection. 

The table can be resized so you can view both the table and the ADB screen. If you click 
on the ADB screen, it will appear on top of the scenic_rivers table. After you resize the box, 
drag it to either the top or the bottom so that you can make it active from the ADB screen. As 
long as a part of the table is visible on the screen, you can click on it to make it active.  

You can view the records as a form by clicking on the View as Form button. If the View 
as Form button disappears as a result of resizing the table, close the table and reopen it by going 
to View->Show Connections and picking the table. 

One advantage of connecting to the table is the ability to enter information into the table 
at the same time as you enter the AU data into the database.  Another advantage of using table 
connections is that you can view the Cycle Tracking table in the ADB.  This will allow you to 
view if there have been any changes to any AU in terms of AU size, naming convention or AU 
ID.  You can also view if there have been any splits or merges since the previous cycle. 
 

4. Close the scenic_rivers table by clicking the X in the upper right corner. 

EPA Assessment Database Version 2 Tutorial 49 



ADB v.2 Tutorial for EPA Regional Users Exercise 6 

Exporting Data 

Another feature of the Connections Module allows you to export data from the ADB to 
Access 97, Access 2000, and SQL Server. You can also choose to export the data as a .csv text 
file, which is illustrated in the following example. 

For this example, let’s say that a water quality manager asks the question: Which AUs 
with a “Fish and Aquatic Life” designated use are on the Category 5 list for causes from Iron? 
In Exercise 1, you were able to use the ADB’s Browse feature to view, sort, and filter the data in 
table format. However, the Browse feature limits the user in performing more custom queries 
required for answering questions such as the one above. By being able to interact directly with 
the ADB tables, the user is able to directly select out data to create a new table that specifically 
answers the questions you want to ask. 

1. Return to the Connections Module by clicking the hammer icon at the top of your 
screen, or access this module through Start->Programs->ADBv.2 for Access-
>Connections.  

2. Choose File->Connect to Database. Click Create New Connection, then click Next.  

3. Choose Microsoft Access and click Next. 

4. In the “Connect to Access” dialog box, click on the navigation button        and navigate 
to the ADBaccess.mdb database in C:/ADB_access and click Open. 

5. Next, check the Save Connection on Finish box. This will allow you to use the same 
connection later after you close the ADB. 

6. Click Test Connection. You should get a message saying “Test Successful.” Click OK, 
then click Finish in the “Connect” dialog box. 

7. Name the connection ADB. Click OK. 

From this point forward, this connection will be available through the Existing 
Connections option. 
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Performing Queries Through the Connections Module 
 

1. Click the Views tab and select the Category5_Causes view. 

 

 

2.  From the Connections menu, select Advanced SQL. The “Advanced SQL” dialog box 
allows you to create a custom query. 

3. Check the boxes beside:  
ID305B, CYCLE, WATER_NAME, USE_DESC, ATTAINMENT_DESC, 
THREATENED_FLAG, CAUSE_NAME, SOURCE_NAME 

4. Check the Select Unique Records box. 

5. Under the “WHERE:” dialog box, select STATE from the drop-down list and enter TN 
in the box to the right of the “=” sign. Click the ADD button.  
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So far, your SQL structure should look like this: 

 
 

6. Under WHERE: Select CAUSE_NAME from the drop-down list and enter Iron in the 
box to the right of the “=” sign. Click the ADD button. 

 

Note: Instead of entering values at the right of the “=” sign, you may use the GET 
VALUES button to access a drop-down list to choose values from a selected list. However, this 
may be a slower option than entering the values directly.  
 

This statement will retrieve from the database all the AUs in the Category 5 causes that 
are in Tennessee and are impaired by Iron. If you save this query, you will be able to recall this 
SQL string at any time in the future. Additionally, because it is a live connection to the database, 
updating the database will also update the query results. 
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7. Click the TEST button.  

This will show you what the table will look like. (You may need to scroll to the right to 
see all the fields.) Note that although this is a table of Category 5 causes, one of the AUs is listed 
as “Fully Supporting.” This is because the “Y” in the Threatened_ Flag field indicates it is a 
threatened water, which puts it in Category 5. 

  

8. Close the table by clicking the X in the upper right corner. 

9. Click the SAVE button. Save the query as IronFilter and click OK. 

10. From the Connections menu, choose View Saved SQL Scripts. (This table can be 
accessed this way at any point in the future.) Double-click on IronFilter. 

11. If you are using the Access version, the table you just created will open. Otherwise, 
enter ADBUSER (or the appropriate password) and click OK. 

12. The table you just created will open. Select one of the cells with Fish and Aquatic Life 
under the USE_DESC field. Right-click on the cell and pick Filter. Only records with 
the Fish and Aquatic Life use should now be visible in the table. 

13. Right-click on the same cell and pick Export Data. Choose the Export as Filtered 
option. 

14. Save the file in the Regional_SampleData folder as Iron.txt. Click Save. In the “Text 
File Export Wizard” window, click Finish to create the text file. 

 

The text file you created above can be used to limit which AUs can be accessed in the 
main “Assessment Units” screen.  
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15. Close the Connections Module and return to the main “Assessment Units” screen in the 

ADB v.2. (If the database is not already open, you can access it through the Start 
menu.) 

16. In the “Select an Assessment Unit” section of the screen, pick Limit by Text File from 
the Limit List By: drop-down list and click Change List. 

17. In the “Limit List By:” dialog box, click the Choose New File button. Navigate to the 
Iron.txt file in your Regional_SampleData folder and click Open. 

18. Pick ID305B from the Choose field to limit by: drop-down list. This will relate the field 
that contains the ID in the Ironfilter.txt table to the AU ID in the ADB v.2. Click Finish.

 

Note: The Limit by List function will only work with lists that have 1,000 IDs or less.  

19. Under the “Select by Assessment Unit” dialog, Click the By ID: drop-down list.  
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You can see that of the records that were in the table, only two are present in this list. 
These are the two records associated with the 1999 cycle. 
 

20. Close the “Assessment Units” screen. 

The Advance SQL feature can be very useful to obtain information over multiple states 
and cycles.  If you have additional time after this exercise, run the following query:    

1. Using the CATEGORY5_CAUSES view, type “TMDL_ID is null and CAUSE_NAME 
is not null” in the where text box.   
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This query will return a list of all AU-cause combinations for all state and cycles in the 
database which do not have an assigned TMDL.  Note that because the “Pollutant_Flag” field 
has not been restricted to “Y”, Category “4c” waters, or waters which impaired by a non-
pollutant, may be present in the list. 

Viewing Changes to AU’s in the Cycle Track table 

1. Open the Connections Module by clicking Start->Programs->ADBv2 for 
[version->Connections.  

2. From the File menu, select CONNECT TO A DATABASE. 

3. In the “CONNECT TO A DATABASE” dialog box, click the Use Existing Database 
Connection radio button and then click NEXT. 

 
4.    In the Existing Connections screen, select the ADB Defined Database and click OPEN.

5.    On the TABLES tab, highlight the CYCLE_TRACK table.  Right click the selected 
table and choose OPEN.  The Cycle Track table in the ADB will open. 
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In this example, you learned how to view which IDs have been Renamed and which IDs 
have be Split.  If there had been any IDs merged in this dataset, you would also be able to view 
that information here. 

Summary 

In this exercise, you learned how to connect to an outside database and bring a table from 
that database into the ADB v.2 and how to sort records in that table. You also learned how to 
perform a custom query within the Connections Module to answer a specific question. Finally, 
you learned how to export a newly created table from a query into a text file and, using the file, 
limit the records in the “Assessment Units” screen. 

In Exercise 7, you will learn how to use GIS data with the information stored in the ADB 
to create maps of water quality data.  You will learn how to do this by linking water quality data 
in .dbf form to an NHD-based shapefile that contains the appropriate surface waterbody 
delineations. 
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Exercise 7. Reviewing GIS Data 

This exercise is intended for users who are already familiar with geographic information 
system (GIS) and reach indexing methodology. If you are unfamiliar with the National 
Hydrography Dataset Reach Indexing please refer to the following Web page: 
http://www.epa.gov/owow/monitoring/georef/index.htm. This site explains the reach indexing 
process and database formats that work well with GIS.  

The IR Reporting guidance requests states to provide spatial files that show the locations 
of assessment units.  Reviewing these spatial data files ensures adherence to the EPA Guidance 
and requirements.  The integrity of the submittals should also be validated.  Usually these 
segments are defined using GIS.  The state GIS submittals should be referenced to the 1:100,000 
scale National Hydrographic Dataset (NHD) and have IDs that match the IDs in the ADB.  Also 
the segments displayed should properly represent the waters identified in the ADB.  Stream 
lengths and Lake/Reservoir areas should be the same between the GIS and ADB information. 

States may submit GIS materials in different formats.  For example, some states may 
submit shapefiles, geodatabases or event tables created with the NHD-Reach Indexing Tool or 
the Hydrography Event Management (HEM) Tool.  This exercise uses a shapefile that was 
created using 1:100,000 NHD layers.  ArcGIS 9.x software will be used to review the data.  For 
other submittal versions, the steps may need to be adjusted in terms of mechanics but 
functionally should remain the same. 

Before you begin this exercise, you need to unzip the GIS_SampleData.zip file to your 
computer’s hard drive. 

Exporting the ADB information 

The first step in reviewing the GIS information against the ADB requires you to export 
the category list from the ADB.  This information can then be joined to the state provided GIS 
data.   

Follow the steps below to export the category list. 

 

EPA Assessment Database Version 2 Tutorial  58 

http://www.epa.gov/owow/monitoring/georef/index.htm


ADB v.2 Tutorial for EPA Regional Users Exercise 7 

1. Open the ADB by clicking Start->Programs->ADB v.2 for Access->ADBv.2.  

2. If you have never accessed a database before using ADB, or if you have deleted or moved 
a database since you last accessed it, you will be prompted to connect to a database.  
(NOTE:  If your computer has been used to access an ADB database before, the ADB 
interface will automatically connect to the database, State and cycle that were chosen 
during your last login.  To select a new database, go to File -> Select Database and browse 
to the appropriate database when prompted.) 

 
3. Navigate to the ADBaccess.mdb database located in C:\Regional Sample Data folder. 

4. If you are prompted for “State,” specify TN for State and click OK. When you get a 
message saying there are no data for this cycle, click No. 

5. Select 1999 for the “Choose Cycle Year” dialog box and click OK. 

6. Under the Data Drop down menu, Select Data Exports. 

 
7. Choose Category Listing from the Select an Export drop-down menu and click the 

Export Data button. 

8. You will be prompted for a location to save the file.  Save the Export file as 
TN_cat_list.csv in the C:\Regional Sample Data folder\GIS.   

9. Click the Close button in the Data Explorts dialog box, then click Exit to close the ADB. 

10. Navigate to the C:\Regional Sample Data folder\GIS, right click on the TN_cat_list.csv 
file and change the file name to TN_cat_list.txt.  A dialog box will appear that says “If 
you change a file name extension, the file may become unstable.  Are you sure you want to 
change it?” Click Yes. 
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Now that we’ve learned how to export the list of IDs and categories from ADB, we’ll 
learn how to import this data into GIS.   
 

1. Open ArcGIS by clicking Start->Programs->ArcGIS->ArcMap.  Open with a new empty 
map.  

2. Click the Add Data button  .  Navigate to the C:\Regional Sample Data\GIS folder 
and select the TN_cat_list.txt file created in step ten above and click Add. 

3. In the Layers list, right click on the TN_cat_list.txt layer and click Open.  The table 
shows the AUs for this state.  The table provides information such as ID, Waterbody 
Name, Location, Category and Size.  Close the attribute table. 

4. Convert the txt file to a .dbf file by right clicking on the Tn_cat_list.txt layer and select 
Data, then Export. 

5.  Navigate to the C:\Regional Sample Data\GIS folder and save the new file as 
TN_cat_list.dbf.  Click Save, then Click OK.  When prompted, add TN_cat_list.dbf to 
the map. 

In this section you learned how to export data from the ADB and import it into ArcGIS.  
The remainder of the tutorial will show you how to compare the state provided GIS files against 
the ADB data. 

Viewing NHD-Based Event Tables as Shapefiles 

NHD event tables can easily be viewed in ArcMap as a shapefile. In this exercise you 
will learn how to add NHD event tables and NHD to ArcMap.  Loading this information to 
ArcGIS allows you to check the projection and coordinate information of the state submitted 
shapefiles.  You can also see if the state submitted shapefiles are compatible with the 1:100,000 
NHD. 

 

1. In ArcMap, Click the Add Data button  .  Navigate to the C:\Regional Sample 
Data\GIS folder and select tn_305b_linear.shp and tn_305b_polygon.shp and click Add.  
(Note: use the CTRL key or shift key to select multiple files)  This adds the state provided 
GIS files to the ArcMap Project. 

2.  Save the project by clicking on File -> Save.   Navigate to the C:\Regional Sample 
Data\GIS folder and save the project as TN_Review.mxd 

With the shapefile added you can check the projection and coordinate system information 
for the state GIS submittal. 
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1. Click once on the tn_305b_linear layer to make it active. 

2. Right click on the tn_305b_linear layer and select Properties. 

3. In the Layer Properties dialog box select the Source tab. Check the projected coordinate 
system information and be sure to record your findings. 

 

 

In this example the projection is in North American Geographic 1983.  You can use 
ArcGIS tools to change the projection if necessary.   Repeat the steps above with the 
TN_305b_polygon layer. 

The next step is to add NHD to the view. With the NHD and state provided shapefile 
loaded to the view you can compare the compatibility of the state submitted layers with the NHD 
layers.   
 

1.  Click the Add Data button  .  Navigate to the C:\Regional Sample Data folder\GIS 
and double click on NHDPlus06040002 folder, next double click on hydrography.  Click 
on NHDflowlines.shp and NHDWaterbody.shp then click Add.  This adds a portion of 
the NHD for TN to the map. 

2. In the Layers List, right click on NHDFlowlines and select Zoom to Layers. 

Now, let’s move the layers and change the legend symbology to make it easier to review 
this data. 
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1. Click on the Display tab under the layers window.  

2. Move the tn_305b_linear layer above the NHDflowlines layer by clicking on the 
tn_305b_linear layer and, with the left mouse bottom held down, slide the layer up.  
Repreat this process and move the tn_305b_polygon layer to below the tn_305b_linear 
layer. 

3. Click on the symbology for the tn_305b_linear layer (the symbology is the colored line 
below the layer name) and under options, select a red color and click OK.   

4. Click on the symbology for the NHDFlowlines layer (the symbology is the colored line 
below the layer name) and under options select a blue color, change the width to 2 and 
click OK.    

5. Click on the NHDWaterbody layer and under options select a blue color and click OK. 

Your project should look similar to the one shown below.  To review this information, 
Zoom in and Pan across the map, turning layers on and off to view the difference between the 
state submittals and the NHD layers.   
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Comparing the GIS and ADB IDs and size information 

In this next section we will learn how to summarize the miles and acres in the GIS 
submittals by the unique state assessment ID in the line and polygon GIS files.  Note that the ID 
name field may vary from state to state.  The summary of entity id/mileage information should 
be compared to the ADB derived list of ENTITY_IDs and sizes.  The purpose of this comparison 
is to identify ADB assessed segments with missing GIS delineation. 

Follow the directions below to summarize the mileage information from the state 
provided GIS files.  

1. In the Layers list, select the tn_305b_linear layer by left clicking on it.  Then right click 
on the highlighted layer and choose Open Attribute Table. 

2. In the attribute table click on the field name ENTITY_ID.  Then right click on this field 
and select Sort Ascending. 

3. Right click on this field name again and choose Summarize.  The Summarize options 
dialog box will appear.  

4. In the Summarize options dialog, under step 1, Select a field to Summarize choose 
ENTITY_ID from the dropdown list.  Under step 2, Choose one or more summary 
statistics to be added to the output table, scroll down to the meters field and click the box 
next to Sum.  Under step 3, specify output table, click the folder icon and navigate to 
C:\Regional Sample Data folder\GIS and change the file name to 
TN_305b_linear_sum.dbf  Click Save then click OK.  
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Repeat the above process for the polygon layer.  (Note: in the summarize dialog box, use 
the sq_km column.)  Also change the file name to TN_305b_Polygon_sum.dbf and save the file 
in C:\Regional Sample Data folder\GIS.   

You have just successfully summarized the size information in meters and square 
kilometers for the GIS layers.  If the length information stored in the ADB is in miles/acres you 
will need to convert the data in order to compare the numbers.  In this exercise the size 
information stored in ADB is in miles.  In this next section we will learn how to do this 
conversion in GIS. 
 

1. Click on the source tab under the layers window.  This will allow you to see the summary 
tables that were just created. 

2. Right click on the TN_305b_linear_sum.dbf file and choose Open. 

 

 
4. The summarize completed dialog box will appear.  It will ask “Do you want to add the 

result table in the map?”  Click Yes. 

5. Close the TN_305b_linear attribute table. 
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3.  In the table window click on the Options button, located at the bottom right hand side of 
the table.  Choose Add Field. 

4. The Add Field Menu should appear.  Enter Calc_Miles as the new field name.  Select 
Double as the field type.  In the field properties section, enter 12 for Precision and 4 for 
Scale.  Click OK. 

 
5. A new field called Calc_Miles has been added to the table.  Right click on the 

Calc_Miles field heading and choose Field Calculator.  You may receive a dialog box 
that says “You are about to do a calculate outside of an edit session.  This method is faster 
than calculating in an edit session, but there is no way to undo your results once the 
calculation begins.  Do you wish to continue?” Click Yes. 
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6. The Field Calculator dialog box will appear.  In the fields section, double click on 
Sum_METERS, this will put the Sum_METERS field in the Calc_Miles= box.  Then 
click on the * operation, available from the right hand side of the dialog box.  Then enter 
(0.0006213711922).  You should now have an equation in the calc_miles= box that reads 
[Sum_METERS] *(.0006213711922).  (Note (.0006213711922) is the multiplier 
necessary to convert meters to miles, depending on the units in the ADB and GIS files you 
may need to use a different multiplier.)  Click on OK. 

 
 
 

The TN_305b_linear_sum.dbf table should now have the mileage calculated in the 
Calc_Miles field.  Check to make sure that the Calc_Miles field now has a new value in each 
record.  Next we will repeat the process for the polygon layer.  Close the tn_305b_linear_sum 
attribute table. 
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1. Click on the Source tab under the layers window.  This will allow you to see the summary 

tables that were just created. 

2. Right click on the TN_305b_polygon_sum.dbf file and choose Open. 

3. In the table window click on the options button, located at the bottom right hand side of 
the table.  Choose Add Field. 

4. The Add Field Menu should appear.  Enter Acres as the new field name.  Select Double 
as the field type.  In the field properties section, enter 12 for Precision and 4 for Scale.  
Click OK. 

 
5. A new field called Acres as now been added to the table.  Right click on the Acres field 

heading and choose Field Calculator.  You may receive a dialog box that says “You are 
about to do a calculate outside of an edit session.  This method is faster than calculating 
in an edit session, but there is no way to undo your results once the calculation begins.  
Do you wish to continue?” Click Yes. 
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6. The Field Calculator dialog box will appear.  In the fields section, double click on 
Sum_SQ_KM, this will put the Sum_SQ_KM field in the Acres= box.  Then click on the 
* operation, available from the right hand side of the dialog box.  Then enter 
(247.1053814672).  You should now have an equation in the Acres= box that reads 
[Sum_SQ_KM] *( 247.1053814672).  (Note: (247.1053814672) is the multiplier 
necessary to convert SQ_KM to Acres.  Depending on the units in the ADB and GIS files 
you may need to use a different multiplier.)  Click OK.  

 
 

The TN_305b_polygon_sum.dbf table should now have the acres calculated.  Check to 
make sure that the acres field has a new value in each record.  Close the TN_305b_polygon_sum 
attribute table. 

Joining and Reviewing the ADB and GIS Data 

In order to perform an adequate quality assurance check of the GIS and ADB ID 
matches, the information needs to be examined in two directions; GIS joined with ADB and then 
ADB joined to the GIS.  When you join the GIS data to the ADB, you will be able to find any 
GIS segments that are not represented it the ADB.  These should be recorded so they can be 
resolved.  Joining the ADB to the GIS lets you see which IDs in the ADB are not represented in 
the GIS layer.  These IDs should also be recorded so they can be resolved.   
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Joining the GIS data with ADB Data 
 

1.  Click on the source tab under the Layers window. 

2.  Right click on the tn_305b_linear_sum.dbf table and select Joins and Relates then 
click on Join. 

3.  The Join Data dialog box should appear.  In this window you will enter the appropriate 
join information.  The default information in the first menu item Join attribute from a 
table is correct.  Under step 1, choose ENTITY_ID.  Next, choose the category listing 
table (tn_cat_list.dbf) and choose ASSESSMENT for the ID join field.  Click OK. 

 
4. Right click on the tn_305b_linear_sum table and choose Open.  Scroll over till you see 

the TN_cat_list.ASSESSMENT.  Click on this column and chose Sort Descending. 

5. The TN_cat_list.Cal_Miles column contains the mileage value from the GIS.  The 
TN_cat_list.water_size column is the length value from the ADB.  The data in these 
columns should be compared for discrepancies.  Close the attribute table. 

 

With this first join you have found IDs that are represented in the GIS, but not in the 
ADB.  You can print this list for review.  You can do this by right clicking on the 
tn_305b_linear_sum.dbf, choose Data then Export.  The export data dialog box will appear.  
Specify an output location and name for the file. 
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Another good review check you can do with this join is to compare the size information 
calculated in GIS with the size information in ADB.   
 

6. Right click on the tn_305b_linear_sum table and choose Open.  Scroll over till you see 
the TN_cat_list.ASSESSMENT.  Click on this column and chose Sort Descending. 

7. The TN_cat_list.Cal_Miles column contains the mileage value from the GIS. The 
TN_cat_list.water_size column is the length value from the ADB.  The data in these 
columns should be compared for discrepancies.  Close the attribute table. 

Before you can perform new joins, you need to remove the existing joins.  Follow the 
instruction below to remove the joins before moving on to the next section. 
 

8. Right click on the TN_305b_linear_sum file and select Joins and Relates then Remove 
Joins, click on Remove All Joins. 

Repeat this process as needed with any other GIS layers. 

Joining the ADB Data with GIS data 
 

1. Click on the Source tab under the Layers window. 

2. Right click on the TN_cat_list table and select Joins and Relates then click on Join. 

3. The Join Data dialog box should appear.  In this window you will enter the appropriate 
join information.  The default information in the first menu item Join attribute from a 
table is correct.  Under step 1, choose ASSESSMENT.  Next, choose 
TN_305b_linear_sum.dbf and choose ENTITY_ID for the ID join field.  Click OK. 
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4. Right click on the TN_cat_list table and choose the Open.  Scroll over to see the 

additional fields that have been added. 

5. Click on ENTITY_ID and select Sort Descending.  Any records in this field with a null 
value means there is data in the ADB that is not represented in the GIS. 

 

With this join you have found IDs that are represented in the ADB, but not in the GIS.  
You can print this list for review.  You can do this by right clicking on the TN_cat_list.dbf 
choose data then export.  The export data dialog box will appear.  Specify an output location and 
name for the file. 
 

6. Right click on the TN_cat_list.dbf file and select Joins and Relates then Remove 
Join(s), click on Remove All Joins. 
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Verify  303(d) GIS Segments 

In this next section we will verify that the GIS referenced segments are in fact the 
appropriate segments and that the ADB information links to the correct segments.  A detailed 
review of the 303(d) (category 5) waters should be preformed.  Categories 1-4 can be done 
through a sampling process.  In the exercise below you will learn how to export a list of the 
category 5 waters for review.   

The example illustrates how to review the category 5 waters. 
 

1. Click on the Source tab under the Layers window. 

2. Right click on the TN_cat_list.dbf table and choose Open. 

3. In the table view, click the options button and then choose “Select By Attributes”.  The 
Select By Attributes dialog box should appear.  In the method box leave the default of 
Create a new selection.  In the box below method, scroll down till you see “Category”.  
Double click on Category, then Single click on the = sign.  Click on the Get Unique 
Values button, then double click on ‘5’.  You should now have a query that reads 
"Category" = '5'.  Click Apply then Close. 
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4. You should now have the category 5 waters highlighted in the TN_cat_list table.  (Note: 
you may have to scroll to the bottom of the table to view the highlighted records).  At the 
bottom of the table view after “Show:” click the Selected button.  The table now shows 
just the selected records. 

5. To export the selected records, click on the Options button, then select Export.  The 
Export Data dialog box will appear.  Leave the default of export: Selected records.  
Navigate to the C:\Regional Sample Data\GIS folder and name the file Cat5_waters.dbf.  
Click OK. 

 
6. When asked if you want to add the file to your map click Yes.  Close the table. 

 

Now that you have a list of the category 5 waters you can join this to the GIS layers to 
review just the 303d waters. 
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7. Right click on the tn_305b_linear file and select Joins and Relates, click on Join.  For 

section 1, select ENTITY_ID, for section 2 select the Cat5_waters table for section 3 
select ASSESSMENT.  Click OK. 

 
8. The list of category 5 waters from the ADB and associated attributes have now been 

added to the shapefile.   Open the attribute table for the tn_305b_linear layer by right 
clicking on the layer name and choosing Open Attribute Table.  Scroll over to the right 
to see the added fields. 

9. In the tn_305b_linear attribute table right click on the Cat5_waters.ASSESSMENT 
column heading and choose Sort Descending.  You can now see which IDs in the GIS file 
have successfully joined with the ADB data. 
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Now you can zoom to individual assessment units and review the location and the 
associated ADB data. 

10. Highlight the records for Little Duck River by clicking on the gray squares to the left of 
the rows and holding down the shift key.  Close the table. 

11. Right click in the map window and choose Zoom To Selected Features.  The map will 
re-center on the selected waterbody.  Review the location and associated ADB Attributes 
for accuracy. 

Alternatively, you can use the Selection menu in ArcGIS to check a stream or lake. 

12. Click on the Selection Menu and choose Select By Attributes. 

13. Create a query, like the one shown below for a waterbody of interest. Click OK.  

Click Here 
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14. Right click in the map window and choose Zoom To Selected Features.  The map will 

re-center on the selected waterbody. 

 

Summary 

This exercise illustrates how you can review GIS submittals against data from the ADB.  
You learned how to export data from ADB and how to load and check state submitted shapefiles.  
For more information on delineating surface waters in a database and associated GIS, see the 
Concepts section of the Georeferencing Web site at 
http://www.epa.gov/owow/monitoring/georef.  More information on the ADB can be found at:  
http://www.epa.gov/waters/adb/  
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