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1. ABOUT THIS BMDS RELEASE 
BMDS maintenance release Version 2.6.0.1 replaces Version 2.6 (Build 2/4/2015).  
 
Check the BMDS web site (http://www.epa.gov/ncea/bmds/index.html) for updates and 
additional information.  
 
 

2. WHAT’S NEW IN BMDS 2.6.0.1 
BMDS 2.6.0.1 contains the following fixes and enhancements: 

 Resolves an issue in BMDS 2.6, which prevented users from specifying parameter 
values for Continuous models. (BMDS still prevents users from specifying the 
Continuous model Alpha parameter to work around an open issue where BMDS 
sometimes reports a non-optimal A3 log likelihood when the Alpha parameter is 
specified.) 

 Resolves an issue with previous versions where BMDS occasionally reported incorrect 
scaled residuals when a session referenced multiple data files with differing dose values.  

 Enhances the Nested models' text results to display the minimum, maximum, and mean 
of the absolute value of the scaled residuals, as well as the minimum, maximum, and 
mean of the scaled residuals. 

 Resolves an issue where BMDS 2.6 could not display plots generated by previous 
BMDS versions.  

 Implements a fix for an intermittent issue where the BMDS Wizard did not import plots 
generated by BMDS 2.4 and later.  

 Correctly validates the v parameter for the Continuous Hill model, an issue since BMDS 
2.3. Although the v parameter must be 0 < v ≤ 1 for Dichotomous Hill, it should be 
unconstrained for the Continuous Hill model. 

http://www.epa.gov/ncea/bmds/index.html
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 Adds an Update button to the About BMDS box (accessible from the Help>About menu 
item). Click the Update button to have BMDS check for and optionally install a BMDS 
update. See Section 7 of this readme file, "Automatically Update BMDS," for more 
information on using the Update feature. 

 

 
3. ICF INTERNATIONAL'S BMDS WIZARD 
The BMDS 2.6.0.1 install package includes ICF International's BMDS Wizard version 1.10, an 
Excel-based tool that facilitates the preparation and organization of and enhances the reporting 
capabilities of BMDS modeling sessions. This install includes multiple Wizard template files that 
are preformatted for continuous, dichotomous, dichotomous-cancer, and multi-tumor datasets. 
BMDS Wizard also supports 32-bit and 64-bit versions of Microsoft Office on Windows 7. 
 
BMDS "power users" employ ICF BMDS Wizard as a shell to simplify the BMD modeling 
process by streamlining data entry, model selection, option file development, output file 
reporting, and model comparisons.  
 
ICF BMDS Wizard 1.10 can also export Microsoft Word-formatted reports that employ the latest 
EPA-approved reporting format (as of September 2014). It can only export reports for 
continuous, dichotomous, and dichotomous-cancer models. 
 
Also note that MS-Combo Wizard v1.10 is compatible only with Wizard v1.10 and will not work 
with previous versions of Wizard. 
 
To run the ICF BMDS Wizard, go to the BMDS 2.6.0.1 program directory and locate the 
"Wizard" subdirectory. Refer to the BMDS Wizard User's Guide PDF located in the Wizard 
subdirectory or the Quick Start tabs in the Wizard templates for details on running the tool. 
 
More information on BMDS Wizard can be found at ICF's site: 
http://www.icfi.com/insights/products-and-tools/bmds-wizard.  
 
If you would like to provide feedback, please email wizard@icfi.com.  

 
 
4. BMDS USAGE TIPS 
1. Non-U.S. users should change the Windows default option for the decimal separator from a 

comma to a period. This option can be found in the Region and Language control panel. 
Using BMDS with a comma as the decimal separator will cause program errors. 

2. Some users have reported that clicking or double-clicking on a Help topic generates the 
message "Navigation to the web page was canceled." Solution: change the security 
permission for the following file in the BMDS folder -- BMDS260.chm -- to "Full Control". If 
you're unable to change the permission, then you will need to work with someone who has 
Administrator rights to make this change. 
 
To change the permission: 

1. Right-click on the BMDS260.chm file in Windows Explorer and select "Properties" 
from the context menu. The Properties dialog box appears. 

2. Click the "Security" tab. 

http://www.icfi.com/insights/products-and-tools/bmds-wizard
mailto:wizard@icfi.com
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3. In the Permissions box at the bottom, click to place a check mark in the "Allow" 
column for "Full control."  
 

3. The column headers for data files should avoid spaces or special characters.  
4. Directory and file names should avoid special characters that may cause problems when 

BMDS tries to open those files later. Please refer to the BMDS help file's Troubleshooting 
topic titled "Avoid Using Windows Reserved Characters in File and Path Names."  

5. The path+filename should not exceed 255 characters. 
6. If you move option (.opt) or data (.dax) files associated with a session, you will need to 

update the sessions that reference those files. 
7. The flexibility in BMDS to create multiple model runs (sessions) with pre-set options for each 

model run should be used with caution so as to avoid invalid or unintended run options with 
a selected model.  

 
 
5. KNOWN BMDS ISSUES 
1. The "BMDL Curve Calc." feature does not always give reasonable results. This feature is not 

a critical component of BMDS and it is recommended that this option be turned off (the 
default choice), particularly if it is causing plot or model convergence problems. 

2. The Rai and van Ryzin model may inaccurately calculate BMDL in some circumstances, 
resulting in the same value for BMD and BMDL.  

3. Specifying or initializing parameter values in the exponential models has been disabled in 
the current release. 

4. For the Power model only: more than one distinct observation per dose group is needed for 
continuous data sets to get the full set of model results (tests of the fit of the model 
compared to models A1 – A3). Although the model will run, error messages for some of the 
internal computations associated with those tests for fit will appear (as a warning message 
in the interface and in the output file). Regardless, the results of any Power model fit to data 
with sample sizes of 1 (per group) should be viewed with caution. While the other BMDS 
models will run N=1 data, the models will not return any test results.  

 
 
6. BMDS SYSTEM REQUIREMENTS 
BMDS requires at least 16 Megabytes of RAM and should run in Microsoft Windows 2000, NT, 
XP, Vista, and 7, however only operation in Windows XP and Windows 7 has been tested at this 
time. BMDS can be installed in any folder for which the user has create/read/write privileges.  
 
BMDS also requires the latest version of .NET (4.0 or later). If your machine is set up to allow or 
be notified of downloads of Microsoft software, then it is likely that that version of the .NET 
framework is already installed. Otherwise, the latest version of .NET for client desktops can be 
downloaded from the Microsoft Download Center 
(https://www.microsoft.com/download/default.aspx).  
 
NOTE: To run the ToxicoDiffusion model included in this version of BMDS, you must install the 
32-bit edition of version 3.1 or later of the R statistical software to your computer (go to 
http://www.r-project.org/ for more information). 
 
 

7. AUTOMATICALLY UPDATE BMDS 

https://www.microsoft.com/download/default.aspx
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If you already have BMDS 2.6 or later installed on your computer, you can use the built-in 
Update facility to check for and automatically install newer versions of BMDS.  
 
By default, BMDS checks weekly for new updates.  
 

1. Select Tools>Preferences>Update.  
2. In the Update Preferences dialog box, click the Check for update now button.  
3. BMDS displays the Update Notification dialog. You can choose to not download the 

update, to download the update and install it yourself later (the default), or to have 
BMDS download and automatically install the update.  

4. If you: 
a. Download and install the software yourself, you can follow the instructions in 

Section 11 of this readme file. The manual installation process is unchanged 
from previous BMDS releases. 

b. Choose to have BMDS automatically download and install the update, then you 
will see an Installation Complete information box with important details on 
working with your old data and session files. See Section 8 of this readme file for 
those details. 

 
Important! Following an automatic installation, the older BMDS version does not shut 
down; it remains open. To use the newly installed BMDS software: 

1. Close the old BMDS version.  
2. Review the readme file to learn about new features, bug fixes, or other need-to-know 

items regarding the new software.  
3. Follow the instructions in this readme file to:  

a. Create a shortcut for the new BMDS version on your desktop  
b. Determine that the new BMDS version works properly on your computer  
c. Fix possible issues with displaying the help file 

 
For information on managing your existing model input and output files after an automatic 
update, see Section 8 of this readme file.  
 
 

8. MANAGING YOUR EXISTING MODEL INPUT AND OUTPUT FILES AFTER AN 
AUTOMATIC UPDATE 

 The automatic BMDS install does not replace or displace your existing model input and 
output files. Your old version of BMDS and related data files remain in their current 
locations. Data files do not have to be moved from their current folder locations to work 
with the new version of BMDS. Follow your organization’s guidelines for locating and 
maintaining data files.  

 Session files contain embedded path names that must be updated if data files are 
moved or copied (e.g., for backup purposes). Session files containing invalid data file or 
output folder locations will not run correctly. 

 
 

9. BMDS ZIP FILE DISTRIBUTION 
Previous BMDS versions used a SETUP.EXE file to create the BMDS directory, add icons to the 
Programs menu, provide an entry in the Add/Remove Programs control panel, and so on. 
However, BMDS is now distributed as a compressed ZIP file and does not employ any 
automated install programs or wizards.  
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The implications of this change are: 
1. Users do not need administrative rights to install BMDS. 
2. BMDS can be installed in any folder for which the user has create/read/write privileges. 
3. Users will need to create their own shortcuts to the program. 
 
See Section 10 for instructions on uninstalling previous versions of BMDS. If you're new to 
BMDS, go to Section 11 (INSTALLING BMDS) and then read the instructions in Section 12 
(CREATING A BMDS DESKTOP ICON) for creating a desktop shortcut. Section 13 includes a 
brief procedure you can run to ensure BMDS is working properly. 

 
 
10. UNINSTALLING PREVIOUS VERSIONS OF BMDS 

It is not necessary to uninstall previous versions of BMDS to install and run BMDS 2.6.0.1. 
However, to maintain the functionality of previous sessions, it is recommended that you retain 
the directory structure for the folders where your previous model runs reside. 
 
To uninstall BMDS 2.1.2 or earlier: The uninstall process will NOT remove any data, option, 
session, output, or plot files created by the user in previous versions of BMDS. 
 

1. Go to the Add/Remove Programs control panel (Windows XP or earlier) or the Programs 
and Features control panel (Windows Vista, Windows 7). 

2. Select the BMDS program in the list. 
3. Select Uninstall.  

 

NOTE: If you don't have the proper rights in the computer, the Remove button will not be 
shown. You should uninstall BMDS by re-starting the original setup.exe file and then choosing 
"Remove Benchmark Dose Software." 
 

 
11. INSTALLING BMDS 2.6.0.1 
If BMDS is already installed on your computer, we recommend using the built-in Update facility. 
See Section 7 of this readme for more information. 
 
BMDS can be unzipped and installed to any folder where the user has create/read/write 
privileges. 
 
To install BMDS: 
 

1. Download the latest BMDS installation file from the BMDS web site 
(http://www.epa.gov/ncea/bmds/dwnldu.html). Installation instructions are also on that 
page.  

2. Locate the BMDS .zip file you downloaded. Typical locations for file downloads are the 
Windows Desktop or the Download directory in My Documents. 

3. In Windows Explorer, double-click the downloaded .zip file. Drag and drop the BMDS260 
folder from the .zip file to the directory of your choice on your computer.  
 
It is recommended that you place the BMDS260 folder (and its subfolders) in the 
simplest, shortest directory, without special characters or spaces, for which you have 
administrative rights (for most EPA users, this will be C:\Users\[EPA user's LAN ID]; for 
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non-EPA users, this could be as simple as C:\).  
 
The Excel-based BMDS Wizard templates will work with BMDS 2.6 installed in any 
directory, however the Wizard folder MUST be installed in the same directory as the 
BMDS260 executable. 

 
After starting BMDS, use the Help feature for further assistance. (See Section 14 to resolve 
issues with displaying the Help file.) If you have problems or concerns, please use the “Problem 
Report” feature listed in the “Help” menu or email BMDS User Support at bmds.ncea@epa.gov. 

 
 

12. CREATING A BMDS DESKTOP ICON 

You may find it more convenient to run BMDS from a desktop shortcut icon. Here's how to 
create one: 
 

1. Delete any older BMDS shortcut icons on your desktop. 
2. In Windows Explorer, navigate to the newly installed BMDS application folder. 
3. Right-click the BMDSxxx.exe file (where "xxx" denotes the current BMDS version 

number). A context menu appears. 
4. Click Send To. A submenu appears. 
5. Click "Desktop (Create Shortcut)". Windows creates a shortcut to the file on your 

desktop. 
 
 

13. DETERMINING WHETHER BMDS IS PROPERLY INSTALLED 
The following procedure will help you determine whether the BMDS components have properly 
loaded and the application is working as expected. 
 

1. Start BMDS. 
2. From the BMDS application menu, choose File>Open>Dose Response Session (.ssn).  

The Open File dialog box should display the contents of the BMDS SessionFiles folder.   
3. Select and open any .ssn file (e.g., Cancer-BMR10.ssn). The Session screen should 

appear. 
4. Click the “Save As” button and resave the session under a different name (e.g., Cancer-

BMR10-test.ssn; you can delete this file later).   
5. Click the “Run” button on the Session screen. Plots and a summary report should 

appear. 
6. At the top of the summary report screen, select File>Export to Excel. Pre-selected 

summary report data should export to several Excel worksheets, with the “Dichotomous 
Format” or Continuous Format” worksheet in the initial view.   

 
If you are able to complete the above steps without difficulty (aside from normal model error 
messages), BMDS is likely to be installed properly and completely. 
 
 

14. IF THE HELP FILE DOES NOT DISPLAY 
Some users have reported that clicking or double-clicking on a Help topic generates the 
message "Navigation to the webpage was canceled." In other cases, the help file Contents 
appear in the navigation pane of the help window, but the topic display pane on the right is 
blank. 
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Cause: This problem is a side effect of Microsoft security updates that were meant to reduce 
vulnerabilities related to help files. 
 
Solution: There are several possible solutions depending on one’s specific configuration. These 
are the most common ways to resolve the problem opening the help file: 
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Solution 1 – This solution works when you get a security warning after double clicking on 
bmds240.chm in your BMDS installation folder: 
 

 
 

1. Uncheck the “Always ask before opening this file” box 
2. Click [Open] 

 
Solution 2 – Unblock the file using Windows Explorer: 
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1. Right-click the bmds240.chm file and choose Properties 
2. On the General tab, click the button labeled "Unblock" 
3. Click OK 

 
Solution 3 – This works for some users who cannot use the first two solutions: 
 

 
1. Right-click the bmds240.chm file and choose Properties 
2. On the General tab, click the button labeled "Advanced" 
3. Uncheck the “File is ready for archiving” box 
4. Click OK 
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Solution 4 – Re-register the help file program with Windows: 

Windows XP 

1. Click the Windows Start menu 
2. Click Run… 
3. Enter: regsvr32 hhctrl.ocx 
4. Click OK 

Windows 7 

1. Click the Windows Start menu 
2. Enter cmd into the search box 
3. Right click on cmd.exe in the results and choose Run as administrator 
4. Enter: regsvr32 hhctrl.ocx 
5. Hit the [Enter] key 
 

Solution 5 – This applies to situation where BMDS is installed on a network drive and the 
previous solutions did not work. NOTE: This solution involves changes to the registry and is 
recommended for experienced users only. Improper changes to the registry can cause 
problems with your computer's operation. The updated registry entry will allow help files from 
the local intranet. 
 

1. We recommend that backing up your registry before proceeding. See 
http://support.microsoft.com/kb/322756 for more information. 

2. Open a text editor (e.g., notepad) and enter the following text. Replace FileServer with 
the name of your file server and SharedFiles with the appropriate share name: 

REGEDIT4 

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp]  

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions] 

"MaxAllowedZone"=dword:00000001 

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions] 

"UrlAllowList"="\\\\FileServer\\SharedFiles;file://\\\\FileServer\\SharedFiles" 

 

 
3. Save the file as PermitIntranetHelp.reg 
4. In Windows explorer, double click on the file you just created 
5. If you get a pop-up window asking if you are sure, click [Yes] 

 

http://support.microsoft.com/kb/322756

